Magic Bullet Looks 4: Compatiblity & System Requirements


Mac OS X:

10.11, 10.12, 10.13, 10.14, 10.15, 11.0 
4 GB of RAM / 800 MB of Hard Drive space

Windows:

Windows 10 (64-bit)
4 GB of RAM / 800 MB of Hard Drive space

Host Requirements:

Adobe Premiere Pro CC 2017, CC 2018, CC 2019, 2020
Adobe After Effects CC 2017, CC 2018, CC 2019, 2020
Apple Final Cut Pro X, 10.2.3 -10.5
Apple Motion 5.2.3 - 5.4.6
Magix Vegas Pro 14 - 18
Avid Media Composer 8.2 - v2020.4
Davinci Resolve 14 - 17
EDIUS 8.1

 

GPU Requirements:

The minimum GPU required is an Intel HD 5000 integrated graphics chip. Of course, newer and faster discrete GPU components from AMD and Nvidia will yield faster performance.

For Nvidia, we recommend 5xx, 6xx, or 7xx series graphics cards; mobile GPUs; or the professional series Quadro cards.

For AMD, we recommend 6000, 7000, or 200 series graphics cards; mobile GPUs; or the professional series FireGL cards.

VRAM size requirements: For HD resolution output, we recommend that your GPU have at least 2 GB of memory. If you are planning on doing high-resolution project in 4K or more, we recommend a GPU with at least 4 GB of memory.

Any CPU from Intel or AMD is supported.

 

Since Magic Bullet Looks 4 is no longer updated/maintained, if it's running a host or operating system outside of these specifications, the program will not be guaranteed to work as it's technically in an unsupported environment.

See the compatibility page for the latest version of Looks to see what its upgraded version will work with.

  

Related FAQs:

Have more questions? Submit a request

Comments