PluralEyes 3.5: Compatibility & System Requirements


Mac OS X:
Mac OS X 10.8.5, 10.9.5, 10.10

Mac Intel
2 GB of RAM
QuickTime

 

Windows:
Windows 7 (64-bit), Windows 8, Windows 10

2 GB of RAM
.NET Framework 3.5 SP1 (Note: this is already included in Windows 7)
QuickTime

 

Editing Programs:
Adobe Premiere Pro CS5.5 CS6, CC 2014, CC 2015.0
Apple Final Cut Pro 7, X (up to 10.2.3)
Avid Media Composer 5.5, 6, 6.5, 7, 8
Sony Vegas Pro 10, 11, 12, 13

Since PluralEyes 3.5 is no longer updated/maintained, if it's running a host or operating system outside of these specifications, the program will not be guaranteed to work as it's technically in an unsupported environment.

 

Have more questions? Submit a request

Comments