Compatibility & System Requirements


Mac OS X:

Mac OS X 10.6.8
Mac OS X 10.7.5
Mac OS X 10.8.5

Windows:

Windows XP SP3 (32-bit)
Windows Vista (32-bit and 64-bit)
Windows 7 (32-bit and 64-bit)

Editing Programs:

Adobe Premiere Pro CS5, CS5.5, CS6
Apple Final Cut Pro 6.0.6, 7.0.3

Since Presto is no longer updated/maintained, if it's running a host or operating system outside of these specifications, the program will not be guaranteed to work as it's technically in an unsupported environment.

Have more questions? Submit a request

Comments