(Premiere) Why does the PluralEyes Premiere Pro Panel only support CC 2014 and higher?


The PluralEyes Premiere Pro panel is an HTML5 extension. Support for HTML5-based panels was not introduced until Premiere Pro CC2014. You can learn more here.

To work with an earlier version of Premiere Pro, either start the project in PluralEyes 4 or manually export the project from Premeire Pro as an XML file, then import the XML file into PluralEyes 4 to sync. Learn more here.

Have more questions? Submit a request

Comments